Per har sönder något

Berätta om dina pågående projekt.
uaxnet
Inlägg: 93
Blev medlem: 12 oktober 2020, 07:43:25

Re: Per har sönder något

Inlägg av uaxnet »

MiaM skrev: 31 augusti 2023, 23:53:19 Ska det vara 8kbyte ram? Tänker att antingen läser man bara en sektor och klarar sig med mindre, eller så läser man ett helt spår och vill därmed ha mer... Kanske räcker med 8k för ett helt spår ifall de kör FM istället för MFM dock?
Det där är intressant. Jag o anders_bzn har diskuterat det. Kortet kan både ha 2kb o 8kb minne och ändras med switch. Hur vida man får hela spåret inläst är dock lite oklart
Användarvisningsbild
anders_bzn
Inlägg: 5400
Blev medlem: 17 december 2008, 19:22:18
Ort: Kävlinge
Kontakt:

Re: Per har sönder något

Inlägg av anders_bzn »

MiaM skrev: 31 augusti 2023, 23:53:19 Ska det vara 8kbyte ram? Tänker att antingen läser man bara en sektor och klarar sig med mindre, eller så läser man ett helt spår och vill därmed ha mer... Kanske räcker med 8k för ett helt spår ifall de kör FM istället för MFM dock?
Ja det ska det, oklart vad man använder minnet till. På andra varianter av detta kort sitter det dock bara 2K. Det finns en bygel som konfigurerar det.
uaxnet
Inlägg: 93
Blev medlem: 12 oktober 2020, 07:43:25

Re: Per har sönder något

Inlägg av uaxnet »

Kollade lite snabbt i en av de sista fw för controllern.
De rensar hela minnet (alla 8k) om det finns vill säga
eprommet har är inmappat på 0x0000 givetvis och minnet börjar på 0x2000
Stacken lägger man på 0x2200 och sedan använder man en del minne under det som register.

Men sen ser det ut som att cachen ändå bara är 0x100 stor (en sektor)
uaxnet
Inlägg: 93
Blev medlem: 12 oktober 2020, 07:43:25

Re: Per har sönder något

Inlägg av uaxnet »

Dags för en liten uppdatering.

Gjorde ett kort för ett tag sedan som är en IDE-USB adapter. Visst det finns ett antal billiga IDE-USB adaptrar men de funkar inte på de tidiga IDE diskarna. Första version av IDE döptes till "XT-IDE" eller ATA-0, Sedan kom ATA-1.
Problemmet med ATA-1 och de moderna IDE-USB adaptrarna är att LBA består av 22 bit medans adaptrarna bara klara av om LBA har 28 bitar eller mer. Så man kan inte använda dessa för att läsa ut diskar.

Efter att ha slitet en del med kortet insåg jag att jag gjort ett lite design fel. Kunde patcha kortet för att då det att semi fungera men inte bra. Så beställde nya kort som kom i veckan.
Lite mer strul med mjukvaran. Framför allt på USB sidan.

Men denna tidig morgon med Adrian Black i bakgrunden så hittade jag problemmet i interupt hanteringen av USB.

Så nu dök den upp som device i datorn
Screenshot from 2023-09-17 07-59-19.png
Och efter lite pillande så fick jag upp alla enheterna i gpart
Screenshot from 2023-09-17 08-02-26.png
Och bara minuter senare dök även filerna upp.
Screenshot from 2023-09-17 08-07-21.png
Nu är det "bara" att fixa implementering av ATA-0 samt ATA-1. Var lite lat i början och tog en modern disk att prova med bara för att jag visste att den fungerade.
Behöver även implementera lite för att kunna trycka ner sektorsinformation utan att använda LBA
20230917_080038.jpg
Du har inte behörighet att öppna de filer som bifogats till detta inlägg.
MattisLind
Inlägg: 733
Blev medlem: 27 maj 2011, 20:27:12
Ort: Älvsjö
Kontakt:

Re: Per har sönder något

Inlägg av MattisLind »

Snyggt jobbat. Mycket bra att kunna läsa CHS diskar via USB!
MiaM
Inlägg: 9767
Blev medlem: 6 maj 2009, 22:19:19

Re: Per har sönder något

Inlägg av MiaM »

Gött att det rör sig framåt!
uaxnet skrev: 17 september 2023, 08:42:55Gjorde ett kort för ett tag sedan som är en IDE-USB adapter. Visst det finns ett antal billiga IDE-USB adaptrar men de funkar inte på de tidiga IDE diskarna. Första version av IDE döptes till "XT-IDE" eller ATA-0, Sedan kom ATA-1.
Finns verkligen "åttabitars-IDE" med i ATA-specen? I så fall finns den publikt tillgänglig?

Nu är det "bara" att fixa implementering av ATA-0 samt ATA-1.[/quote]Mitt intryck är att det finns flera varianter av "IDE-ungefär" med åttabitarsövefföring.

Specifikt så har jag minnen av att ha försökt köra en Seagate ST351 A/X mot en A590 SCSI+"XT-IDE"-kontroller för Amiga utan nån framgång.

Här har vi en tråd där nån försökt samma sak fast en PC gjord av Commodore:
https://forum.vcfed.org/index.php?threa ... ive.52121/

Specifikt så fanns ingen standard för hårdvaruregister på 8-bitars MFM-kontrollerkort för PC, så olika tillverkare använde sin egen sådan variant när de gjorde "XT-IDE"-diskar, verkar det som.

WD 8-bit-"IDE" har specifikt enbart två adressledningar. Vanlig ATA/16-bit IDE har tre.

I en av alla Facebookgrupper för folk som har Sharp åttabitarsdatorer (MZ-80, 700, 800, 1500 och vad de heter) så har nån ett par gånger postat bilder av nån slags burk med ett interface som om jag minns rätt är gjort av WD, som både agerar floppykontroller och MFM-kontroller, med åttabitars databuss och som verkar vara mer eller mindre registerkompatibelt med 16-bitars IDE. Tyvärr är det en såndär trög person som postar samma "vad ska jag göra för att få igång denna"-fråga och bara vill ha länk till en image till en bootdisk (som antagligen fattas sen många++ år) och verkar ha noll intresse av att diskutera möjligheten att skriva modern mjukvara för att åtminstone dumpa innehåller och ev skriva modern driver.
uaxnet
Inlägg: 93
Blev medlem: 12 oktober 2020, 07:43:25

Re: Per har sönder något

Inlägg av uaxnet »

Kvällens uppdatering

Inte så mycket gjort ikväll men har fått igång ett seriesnöre över usb samtidigt som enheten är en usbdisk.

Nästa steg är att börja skriva lite konfigurationskod så att man kan ändra mode på enheten via serieporten
Screenshot from 2023-09-18 20-48-04.png
Du har inte behörighet att öppna de filer som bifogats till detta inlägg.
uaxnet
Inlägg: 93
Blev medlem: 12 oktober 2020, 07:43:25

Re: Per har sönder något

Inlägg av uaxnet »

Liten uppdatering.

Har jobbat en del med mitt Gotek kort
20230927_082758.jpg
En del jobb med att få igång koden på esp32 att hantera en webserver, ftp samt webdav mot SD-kortet.
Speciellt webdev tog sin tid, för jag skapade givitvis en egen bugg som det tog lång tid att hittade.
Men till slut så dök SD kortet upp i datorn.
Screenshot from 2023-09-24 22-35-48.png
Nästa sak blev att kunna prata med orginal flashfloppy, jag har inte velat ändra koden alls i flashfloppy utan helt kunna köra allt hyffsat oberoende på vad som händer i flashfloppy projektet.
Så en del jobb med att sätta upp i2c mot flashfloppy. Flashfloppy använder i2c för display samt en funktion där man kopplar in ett extrakort för att göra on screen display. Denna funktion utnyttjar jag då det finns möjlighet att föra över knapptryckningar etc.
Men det tog en del letande innan jag fick det att fungerar. Det visade sig att man behöver en riktigt display inkopplad samtidigt för att få det att fungera.
Iom att jag kör esp32 som i2c slave så kan jag bara kör den med en slave adress. Vet någon om något sätt att köra flera slave på samma i2c så säg till. Vet att det går på stm saker.
Så lite patch på kortet och köra två i2c slavar med två olika hårdvaru interface i esp32.
När jag väl fick upp att man svara även på display anropet så hoppade OSD igång

Sen blev det lite web på esp32 och se på f.n om man inte kan både visa data samt styra flashfloppy nu. Med samma möjlighet som flashfloppy via osd där man har en meny
Screenshot from 2023-09-27 08-26-43.png
Du har inte behörighet att öppna de filer som bifogats till detta inlägg.
uaxnet
Inlägg: 93
Blev medlem: 12 oktober 2020, 07:43:25

Re: Per har sönder något

Inlägg av uaxnet »

Hej

Har gjort rätt många renoveringar sista tiden, dock utan att skriva så mycket.

Har även ett större projekt som rullar på i bakgrunden. Men det kommer mer om det sen.

Dagens fråga, vad är det för dator som är på bänken idag??
20231106_214428.jpg
Du har inte behörighet att öppna de filer som bifogats till detta inlägg.
Användarvisningsbild
anders_bzn
Inlägg: 5400
Blev medlem: 17 december 2008, 19:22:18
Ort: Kävlinge
Kontakt:

Re: Per har sönder något

Inlägg av anders_bzn »

Jag antar att jag inte får svara…
uaxnet
Inlägg: 93
Blev medlem: 12 oktober 2020, 07:43:25

Re: Per har sönder något

Inlägg av uaxnet »

Anders vi kan avvakta o se om någon som inte har förhandsinformation kan list ut det....
Mindmapper
Inlägg: 6339
Blev medlem: 31 augusti 2006, 16:42:43
Ort: Jamtland

Re: Per har sönder något

Inlägg av Mindmapper »

Var länge sedan nu, men kan det vara en JET80. Tror det var så den hette en CP/M dator.
uaxnet
Inlägg: 93
Blev medlem: 12 oktober 2020, 07:43:25

Re: Per har sönder något

Inlägg av uaxnet »

Helt rätt!!.

Fick med 3st Jet80 när jag köpte en pdp11. Är lite fundersam.. Enligt internet sägs det att det skulle ha sålts 20000st, det finns väldigt få kvar idag vad jag vet och material är det sämre med.
Just denna skulle inte kör cp/m utan bridos, en cp/m fork mer eller mindre. De måste varit dyra att tillverka, man handlödde av komponenter från ampex210 kort och satte på jet-80 kortet.

Tyvärr har jag ingen floppy till dem så det blir väl inte mycket testande. Det ser ut som att floppyn kommunikationen gick över ett seriesnöre. Det blir väl inte lätt att göra någon egen gotek av det.
Har arkiverat en del material som jag fått tag i här. https://git.sweproj.com/ABC80/jet80

Håller på att fixa med skärmen nu så att jag kanske kan få bild i varjefall
Användarvisningsbild
Glenn
Inlägg: 33495
Blev medlem: 24 februari 2006, 12:01:56
Ort: Norr om Sthlm
Kontakt:

Re: Per har sönder något

Inlägg av Glenn »

Var inte JET80 ansedda som billiga ?
guckrum
Inlägg: 1652
Blev medlem: 19 juni 2012, 09:04:27
Ort: Lund

Re: Per har sönder något

Inlägg av guckrum »

Floppy över seriesnöre...
Skriv svar