Buggfix Plus
Aktuellt datum och tid: 10.42 2019-10-16

Alla tidsangivelser är UTC + 1 timme




Svara på tråd  [ 13 inlägg ] 
Författare Meddelande
InläggPostat: 09.33 2019-08-23 

Blev medlem: 08.30 2007-05-15
Inlägg: 159
Ort: Karlstad
Jag har strul med att MOC:en går sönder, men jag har inte lyckats hitta vad som pajar den. Ska forska vidare i det men någon kanske har erfarenhet och kan guida mig i rätt rikting? Bifogar schema på TRIAC-lösningen och Varistorskyddet på inkommande fas. Lasten är en motor max 7VA. En shunt eller en växelventil för radiatorsystem.
När MOCen går sönder så blir problemet att den inte stryper ordentligt. den skickar ut allt mellan 40-130 VAC enligt RMS-multimeter. Det knäpper i ventilen som låter som att den tänder en kvadrant. Inte kunnat verifiera med Oscilloskop dock.

Vad mer kan man göra för att skydda MOCen?


Logga in för att visa de filer som bifogats till detta inlägg.


Upp
 Profil  
 
InläggPostat: 20.58 2019-08-23 

Blev medlem: 15.28 2011-10-31
Inlägg: 1234
Ort: Linköping
Är V3 monterad, står not mount?
Lite udda att ha den mot PE.

Kan det vara en flyback från lasten som dödar MOC?

Koppla in diffprobe och kolla signalen över MOC med skåpet.


Upp
 Profil  
 
InläggPostat: 21.37 2019-08-23 
Användarvisningsbild

Blev medlem: 20.23 2005-08-06
Inlägg: 24795
Ort: Oskarshamn (En bit utanför)
Min första tanke var att fokusera (mäta) på R22 och ev. öka den.

Hur ofta ger MOC’en upp?
Varje test eller varannan åskknall?

Har du provat ett längre test?
Ett par dygn t.ex.

Gkar:
Det är nog mest en skiss av själva komponenten. Men visst, det finns apparater där man har gjort så. Kopplat till PE alltså.


Upp
 Profil  
 
InläggPostat: 06.44 2019-08-26 

Blev medlem: 08.30 2007-05-15
Inlägg: 159
Ort: Karlstad
Det är iaf inte relaterat till (endast) åska då den går sönder även utan åskväder, så jag misstänker att lasten är den skyldige. Startström eller spänningsspik vid frånslag skulle jag gissa.
Det är svårt att reproducera att den går sönder, det sker väldigt sällan, men det sker. kortet körs 24-7 så långtest pågår konstant, men jag vet inte hur jag ska mäta riktigt för att fånga ploblemet eller finna en bra lösning. :humm:


Upp
 Profil  
 
InläggPostat: 08.30 2019-08-26 
Användarvisningsbild

Blev medlem: 14.52 2005-01-10
Inlägg: 24090
Ort: Aabenraa, Danmark
Har designad med MOC och aldrig haft problem.
Kör mot BT136.

Man det vara TRIAC'en som är besvärlig?


Upp
 Profil  
 
InläggPostat: 22.48 2019-08-26 

Blev medlem: 15.28 2011-10-31
Inlägg: 1234
Ort: Linköping
Jag skulle också höja R22 kraftigt.
Rätt sätt att prova transienter är att ha en transientgenerator för förslagsvis 61000-4-5. Det är dock en ganska dyr låda, kostar som en Volvo.
https://en.wikipedia.org/wiki/IEC_61000-4-5.

En varistor mellan L & N gör säkert nytta.


Upp
 Profil  
 
InläggPostat: 07.13 2019-08-27 

Blev medlem: 08.30 2007-05-15
Inlägg: 159
Ort: Karlstad
Enligt appnoten ska Rgate vara 100-500 Ohm. Skulle det göra så stor skillnad från 360 till 500?


Upp
 Profil  
 
InläggPostat: 08.13 2019-08-27 
Användarvisningsbild

Blev medlem: 14.52 2005-01-10
Inlägg: 24090
Ort: Aabenraa, Danmark
I min konstruktion från 2005 är det 220Ω som gäller - och det har inte varit rapporter om problem med det.
Enheten hade 4 st TRIAC med var deras MOC och det är såld ett större antal enheter.

Så jag menar att kunde påstå att konstruktionen som sådan är ganska OK.


Upp
 Profil  
 
InläggPostat: 09.44 2019-08-27 
Användarvisningsbild

Blev medlem: 18.04 2009-08-16
Inlägg: 10945
Testa en moc3051 och se om det hjälper.


Upp
 Profil  
 
InläggPostat: 12.39 2019-08-27 

Blev medlem: 08.30 2007-05-15
Inlägg: 159
Ort: Karlstad
Icecap skrev:
I min konstruktion från 2005 är det 220Ω som gäller - och det har inte varit rapporter om problem med det.
Enheten hade 4 st TRIAC med var deras MOC och det är såld ett större antal enheter.

Så jag menar att kunde påstå att konstruktionen som sådan är ganska OK.

Till vilken typ av last?


Upp
 Profil  
 
InläggPostat: 18.13 2019-08-27 
Användarvisningsbild

Blev medlem: 14.52 2005-01-10
Inlägg: 24090
Ort: Aabenraa, Danmark
1 st rent resistiv (1kW värmespiral).
2 st med motorer (kortsluten rotor?) typ 35W.


Upp
 Profil  
 
InläggPostat: 20.29 2019-08-28 

Blev medlem: 15.28 2011-10-31
Inlägg: 1234
Ort: Linköping
Jag har konstruktioner utan R22.

Vad händer om triacen inte tänder eller har för låg hållström, vilket den får under korta perioder när man stänger av MOC.
Dvs, om CPU stänger av MOC mitt i en period och hållströmmen inte räcker för Triacen...
Kan effekten då bli för hög igenom MOC-triacen?

230V / ca 700 ohm -> ca 300mA. MOC är specad 50-100mA typiskt.


Upp
 Profil  
 
InläggPostat: 12.51 2019-08-29 
Användarvisningsbild

Blev medlem: 14.52 2005-01-10
Inlägg: 24090
Ort: Aabenraa, Danmark
Hmmmm... driver kopplingen en motor med kummukator?
Det kunde i så fall förklara en del anser jag.


Upp
 Profil  
 
Visa inlägg nyare än:  Sortera efter  
Svara på tråd  [ 13 inlägg ] 

Alla tidsangivelser är UTC + 1 timme


Vilka är online

Användare som besöker denna kategori: Inga registrerade användare och 1 gäst


Du kan inte skapa nya trådar i denna kategori
Du kan inte svara på trådar i denna kategori
Du kan inte redigera dina inlägg i denna kategori
Du kan inte ta bort dina inlägg i denna kategori
Du kan inte bifoga filer i denna kategori

Sök efter:
Hoppa till:  
   
Drivs av phpBB® Forum Software © phpBB Group
Swedish translation by Peetra & phpBB Sweden © 2006-2010