Linux Mint långsam boot, uppstart

C, C++, Pascal, Assembly, Raspberry, Java, Matlab, Python, BASIC, SQL, PHP, etc.
Haralt
Inlägg: 567
Blev medlem: 15 november 2016, 00:19:11

Linux Mint långsam boot, uppstart

Inlägg av Haralt »

Halloj gott folk!
Jag har en gammal, bärbar dator, ca 10 år med fabriksinstallerat Windows Vista:
Acer Aspire 5315 med Windows Vista 32-bit, 120 Gb hårddisk, Celeron dual-core T1400 1,73 Ghz, 533 MHZ FSB, 512 kB l2 cache, 2GB DDR2,
Den fungerar ännu klanderfritt, batteriet är dock kass så den måste vara elnätansluten.

Jag brände en DVD-skiva med iso-fil med Linux Mint Cinnamon 19.3 och installerade Linux på denna bärbara datar. Linux märkte tydligen att det redan fanns Windows-operativsystem på datorn, och skrev inte över det.
När datorn startas, kan man välja om man vill köra Vista eller Linux. Bra.
Det som är litet besynnerligt är att uppstarten av Linux tar väääldigt lång tid, ca 5 minuter. När det väl har startat funkar Linux bra.
Vista startar som det tidigare har gjort, inte speciellt snabbt.
Någon som har en idé vad det kan bero på? För ca 8 år sedan installerade jag på den Linux OpenSuse och testade litet med det.

Jag körde en del kommandon:

linux@LinuxMint:~$ inxi -Fxz
System:
Host: LinuxMint Kernel: 5.0.0-32-generic i686 bits: 32 compiler: gcc
v: 7.4.0 Desktop: Cinnamon 4.4.5 Distro: Linux Mint 19.3 Tricia
base: Ubuntu 18.04 bionic
Machine:
Type: Other-vm? System: Acer product: Aspire 5315 v: V1.42
serial: <filter>
Mobo: Acer model: Acadia v: V1.42 serial: <filter> BIOS: Acer v: 1.42
date: 06/11/2008
Battery:
ID-1: BAT0 charge: 2.8 Wh condition: 2.8/48.6 Wh (6%)
model: SANYO GC86508SAT0 status: Full
CPU:
Topology: Dual Core model: Intel T1400 bits: 64 type: MCP arch: Core Merom
rev: D L2 cache: 512 KiB
flags: lm nx pae sse sse2 sse3 ssse3 bogomips: 6916
Speed: 1729 MHz min/max: N/A Core speeds (MHz): 1: 1729 2: 1729
Graphics:
Device-1: Intel Mobile GM965/GL960 Integrated Graphics
vendor: Acer Incorporated ALI driver: i915 v: kernel bus ID: 00:02.0
Display: x11 server: X.Org 1.20.4 driver: modesetting unloaded: fbdev,vesa
resolution: 1280x800~60Hz
OpenGL: renderer: Mesa DRI Intel 965GM x86/MMX/SSE2 v: 2.1 Mesa 19.0.8
direct render: Yes
Audio:
Device-1: Intel 82801H HD Audio vendor: Acer Incorporated ALI
driver: snd_hda_intel v: kernel bus ID: 00:1b.0
Sound Server: ALSA v: k5.0.0-32-generic
Network:
Device-1: Broadcom and subsidiaries NetLink BCM5906M Fast Ethernet PCI
Express
vendor: Acer Incorporated ALI driver: tg3 v: 3.137 port: 5000
bus ID: 05:00.0
IF: enp5s0 state: down mac: <filter>
Device-2: Qualcomm Atheros AR242x / AR542x Wireless Network Adapter
vendor: AMBIT Microsystem AR5BXB63 802.11bg NIC driver: ath5k v: kernel
port: 5000 bus ID: 06:00.0
IF: wlp6s0 state: up mac: <filter>
Drives:
Local Storage: total: 111.79 GiB used: 6.51 GiB (5.8%)
ID-1: /dev/sda vendor: Western Digital model: WD1200BEVS-22UST0
size: 111.79 GiB
Partition:
ID-1: / size: 14.16 GiB used: 6.51 GiB (46.0%) fs: ext3 dev: /dev/sda6
Sensors:
System Temperatures: cpu: 48.0 C mobo: N/A
Fan Speeds (RPM): N/A
Info:
Processes: 163 Uptime: 30m Memory: 1.89 GiB used: 471.1 MiB (24.4%)
Init: systemd runlevel: 5 Compilers: gcc: 7.5.0 Shell: bash v: 4.4.20
inxi: 3.0.32




linux@LinuxMint:~$ systemd-analyze
Startup finished in 2min 12.056s (kernel) + 43.193s (userspace) = 2min 55.249s
graphical.target reached after 27.117s in userspace
linux@LinuxMint:~$


linux@LinuxMint:~$ systemd-analyze blame
16.008s apt-daily.service
10.004s dev-sda6.device
8.645s systemd-journal-flush.service
6.510s lvm2-monitor.service
6.128s ufw.service
6.014s networkd-dispatcher.service
5.658s apparmor.service
5.500s udisks2.service
5.449s ModemManager.service
5.139s ubuntu-system-adjustments.service
5.019s accounts-daemon.service
4.506s NetworkManager.service
4.398s systemd-resolved.service
4.397s systemd-timesyncd.service
3.851s thermald.service
3.125s dns-clean.service
3.070s grub-common.service
2.694s systemd-tmpfiles-setup-dev.service
2.659s gpu-manager.service
2.560s polkit.service
2.355s avahi-daemon.service
2.298s alsa-restore.service
2.227s lm-sensors.service
2.213s rsyslog.service
2.211s pppd-dns.service
2.123s systemd-logind.service
2.027s speech-dispatcher.service
1.990s systemd-tmpfiles-setup.service
1.983s kerneloops.service
1.865s upower.service
1.743s swapfile.swap
1.514s keyboard-setup.service
1.358s colord.service
1.142s apt-daily-upgrade.service
1.121s systemd-rfkill.service
1.085s wpa_supplicant.service
1.058s systemd-udevd.service
950ms networking.service
922ms lightdm.service
913ms systemd-modules-load.service
913ms plymouth-quit-wait.service
785ms plymouth-start.service
742ms systemd-sysctl.service
691ms systemd-udev-trigger.service
588ms systemd-journald.service
588ms kmod-static-nodes.service
586ms sys-kernel-debug.mount
565ms console-setup.service
477ms user@1000.service
470ms packagekit.service
339ms dev-hugepages.mount
337ms dev-mqueue.mount
313ms fstrim.service
290ms systemd-random-seed.service
244ms systemd-update-utmp-runlevel.service
220ms hddtemp.service
207ms rtkit-daemon.service
187ms systemd-remount-fs.service
186ms blk-availability.service
166ms systemd-backlight@backlight:acpi_video0.service
129ms setvtrgb.service
94ms plymouth-read-write.service
70ms systemd-update-utmp.service
50ms systemd-tmpfiles-clean.service
16ms ureadahead-stop.service
15ms systemd-user-sessions.service
13ms sys-kernel-config.mount
12ms sys-fs-fuse-connections.mount
12ms openvpn.service
Senast redigerad av Haralt 12 december 2020, 21:46:12, redigerad totalt 1 gång.
Användarvisningsbild
Lasp
Inlägg: 10597
Blev medlem: 1 juli 2011, 19:09:09
Ort: Helsingborg

Re: Linux Mint långsam boot, uppstart

Inlägg av Lasp »

Oouf den listan orkar jag inte köra igenom.
Gör om allt.
Kör GParted och blås hårddisken tom.
Kör in Linux på nytt, det skall inte ta den tiden alls.
Haralt
Inlägg: 567
Blev medlem: 15 november 2016, 00:19:11

Re: Linux Mint långsam boot, uppstart

Inlägg av Haralt »

Jamen, jag vill gärna ha Windows Vista kvar på bärbara datorn.
Användarvisningsbild
arvidb
Inlägg: 4210
Blev medlem: 8 maj 2004, 12:56:24
Ort: Stockholm

Re: Linux Mint långsam boot, uppstart

Inlägg av arvidb »

Boota maskinen utan grafisk "splash-screen" så du ser vad som händer:

Jag har ingen Mint-maskin som jag kan testa på, men gissningsvis används grub som bootloader (skärmen där du får välja mellan att boota Windows och Linux). Där brukar det finnas ett alternativ att redigera boot-alternativen (har ett svagt minne av att man ska trycka 'e', men det kan mycket väl vara fel).

Gå till raden som innehåller "quiet splash" och ta bort de orden. Ändringar du gör här är tillfälliga och gäller bara denna boot. Boota (F10?) och se om du får mer info om vad som händer.
Användarvisningsbild
JimmyAndersson
Inlägg: 25381
Blev medlem: 6 augusti 2005, 21:23:33
Ort: Oskarshamn (En bit utanför)
Kontakt:

Re: Linux Mint långsam boot, uppstart

Inlägg av JimmyAndersson »

Två frågor:

1) Vad har den använts till?
2) När bytte du hårddisk senast?

Jag tror nämligen att hårddisken är sliten
och jag misstänker att svaren på frågorna kommer visa det. :)

Edit: Såg att svaret på en fråga fanns, så jag tog bort den frågan.
Haralt
Inlägg: 567
Blev medlem: 15 november 2016, 00:19:11

Re: Linux Mint långsam boot, uppstart

Inlägg av Haralt »

Tack för engagemanget och svaren.
Denna bärbara dator har originalhårddisken och har inte använts senaste ca 4 åren utan legat oanvänd pga skaffat en nya bärbar. Jag tror inte heller jag har behövs reparerar operativsystemet Vista. Den har använts som kontorsdator när jag är ute på uppdrag hos kunder. Inte använts så väldigt mycket. Kan man med kommando fråga efter hur många timmar hårddisken rullat? Det kan vara någon gammal Grub som spökar, jag vet jag pillade med sådan för ca 5 år sedan i samband med jag installerade OpenSuse(=Linux) på den.
Skriv svar