Buggfix Plus
Aktuellt datum och tid: 13.29 2019-08-20

Alla tidsangivelser är UTC + 1 timme




Svara på tråd  [ 500 inlägg ]  Gå till sida Föregående  1 ... 30, 31, 32, 33, 34
Författare Meddelande
InläggPostat: 23.03 2019-06-14 

Blev medlem: 09.06 2016-12-01
Inlägg: 739
Ort: Marks Kommun
Felet är nog hittat, själva kompilatorn hade hängt sig, efter en "master reset" (ryckte ur sladden) så funkar det igen, så... pååt igen!!


Upp
 Profil  
 
InläggPostat: 22.16 2019-06-19 

Blev medlem: 09.06 2016-12-01
Inlägg: 739
Ort: Marks Kommun
Sitter just nu och klurar med STM32 modulen "blue pill". Den har 12 bitars analogconverter istället för 10 bitars som på Nano:n. Jag blir nu tvungen att bitskifta 2 resp 4 gånger för att få rätt upplösning men det är inga problem. Jag har även provat interruptprogrammet men det är nåt som går snett där. Den funkar men jag tror att när intrruptrutinen kallas. Spridarutgångarna får en felsignal då och lite random, speciellt på högre varvtal. Jag misstänker själv att jag behöver göra ett nytt program med ett annat tänk lite här och var?


Upp
 Profil  
 
InläggPostat: 06.16 2019-06-24 

Blev medlem: 09.06 2016-12-01
Inlägg: 739
Ort: Marks Kommun
Jag har fått lite hjälp med programmeringen/felsökningen nu och fyra ögon ser mer och förstår mer än två. Om jag inte lyckas med att få "Blue Pill" modulen att fungera som jag vill så har jag en idé om att köra vidare med Nano-modulen och köra förutom dom fyra spridarutgångarna även använda tre PWM utgångar för att styra bränsletryck, bränslemängd och turbotryck. Denna sista motor har inte någon spjällmotor mellan fyra eller åtta insugningsventiler så den styrningen bortfaller. En Nano skulle klara detta precis om den rent kapacitetsmässigt klarar allt på en gång?
Då jag är "inkörd" på Nano-Uno moduler så kommer jag i alla fall att försöka lösa detta på mitt sätt så långt det går. Interrupt blir tvunget...


Upp
 Profil  
 
InläggPostat: 08.29 2019-07-07 

Blev medlem: 09.06 2016-12-01
Inlägg: 739
Ort: Marks Kommun
Min hjälpare har nu gjort om coden från Arduino:n till att passa Nucleomodul STM32F446 och det har varit en del flaskhalsar på vägen... Nu skall vi göra en adapter från NANO:ns 30 poler till Nucleos många mera poler och ett annan storlek och utförande på inkopplingen.


Upp
 Profil  
 
InläggPostat: 00.33 2019-07-18 

Blev medlem: 09.06 2016-12-01
Inlägg: 739
Ort: Marks Kommun
Ett annat problem som dykt upp är att NANO:n är 5 voltsdriven medans STM32Fxxx är 3,3 voltsdriven. Detta innebär andra MOS-transistorer och en annan analog referensspänning. Ev så skulle man kanske bygga nån slags push-pull drivsteg till MOS:arna och behålla dom här IRFZ44N som jag kör i dag? Nu har jag inga som helst värmeproblem på spridarslutstegen men den MOS:en som driver elfläkten blir ljummen... (Det går ca 10 Amp hackad ström genom den kontinuerligt) Är det någon som har förslag på push-pull lösning? Skall man göra den med nån färdig ic eller med transistorer/motstånd?


Upp
 Profil  
 
Visa inlägg nyare än:  Sortera efter  
Svara på tråd  [ 500 inlägg ]  Gå till sida Föregående  1 ... 30, 31, 32, 33, 34

Alla tidsangivelser är UTC + 1 timme


Vilka är online

Användare som besöker denna kategori: PeterH och 4 gäster


Du kan inte skapa nya trådar i denna kategori
Du kan inte svara på trådar i denna kategori
Du kan inte redigera dina inlägg i denna kategori
Du kan inte ta bort dina inlägg i denna kategori
Du kan inte bifoga filer i denna kategori

Sök efter:
Hoppa till:  
   
Drivs av phpBB® Forum Software © phpBB Group
Swedish translation by Peetra & phpBB Sweden © 2006-2010