Buggfix Plus
Aktuellt datum och tid: 06.59 2019-06-25

Alla tidsangivelser är UTC + 1 timme




Svara på tråd  [ 10 inlägg ] 
Författare Meddelande
 Inläggsrubrik: Problem med givare
InläggPostat: 19.57 2004-08-11 
EF Sponsor
Användarvisningsbild

Blev medlem: 21.52 2003-05-28
Inlägg: 1569
Ort: Skåne - Lund
Jag har ett 24v system som normalt ska ha en 160 Ohms resistivgivare (potensiometer).
Problemet är att jag bara har en 10Mohms givare.

Bild


På något sätt får jag anpassa systemet till 10M ohms givare.

10M ohm givaren rör sig inte på hela skalan 0-10M utan den rör sig mellan 3M-6M ohm.

Dvs 3M-6M =>4-20mA

Jag har klurat på lite olika lösningar med får inte något att fungera.

det jag har funderat på är en strömgenerator:
Bild

med det blir svårt att anpassa gränserna.

Ett annat alternativ skulle kunna vara att använda en OP (V-I).

Ett tredje alternativ är ett använda en uC med det ska helst undvikas.


Upp
 Profil  
 
 Inläggsrubrik:
InläggPostat: 20.53 2004-08-12 
EF Sponsor
Användarvisningsbild

Blev medlem: 12.22 2003-11-16
Inlägg: 13248
Ort: i det mörka småland
skulle gjort det i två steg
första att omvandla motstånd till spänning
andra spänning till strömgenerator

första så skulle jag prova att ha en bra opbaserad konstantströmsgenerator och ur den få spänningen, skala och nolla den så man får lämpligt sving på den

och sen en bra opbaserad spännings>strömgenerator


Upp
 Profil  
 
 Inläggsrubrik:
InläggPostat: 20.54 2004-08-15 
EF Sponsor
Användarvisningsbild

Blev medlem: 21.52 2003-05-28
Inlägg: 1569
Ort: Skåne - Lund
Problemet med en konstantströmsgenerator är att strömmen blir så liten ~2,5uA.

En lösning med en spänningsdelare som ovan borde vara bättre. En resistor är trots allt en implementation av en strömgenerator visserligen en väldigt dålig men vad gör det. Man får leva med att det blir lite olinjärt.

Det finns ingen annan som har en idé, jag vet att det finns flera duktiga analog/op konstruktörer :wink:


Upp
 Profil  
 
 Inläggsrubrik:
InläggPostat: 20.25 2004-08-17 
EF Sponsor
Användarvisningsbild

Blev medlem: 12.22 2003-11-16
Inlägg: 13248
Ort: i det mörka småland
inga problem med en en lämplig konstanströmsgenerator
däremot så bör ju ett motstånd vid fuskkonstantström gärna vara 100 * lasten

hur hög noggranhet måste du ha på konstruktionen?

kollade igenom opböckerna och hittade både konstantströmsgenerator och v>4-20 mA


Upp
 Profil  
 
 Inläggsrubrik:
InläggPostat: 22.46 2004-08-17 
EF Sponsor
Användarvisningsbild

Blev medlem: 21.52 2003-05-28
Inlägg: 1569
Ort: Skåne - Lund
Vad menar du med 100 * lasten, vilken last?

Noggrannheten behöver inte vara så bra, bara den rör sig någorlunda, Givaren kommer sedan att styra en av/på reglering.

Har du några bilder på kopplingarna?

Jag kom på att man kanske kan använda en OP som I-I direkt. Men det finns en massa frågor.
Systemet ska vara till en PT100 givare men jag kan ingenting om denna industristandard.


Upp
 Profil  
 
 Inläggsrubrik:
InläggPostat: 17.58 2004-08-18 
EF Sponsor
Användarvisningsbild

Blev medlem: 12.22 2003-11-16
Inlägg: 13248
Ort: i det mörka småland
ok, om det du har som givare är på 1k så bör man man mata det via ett 100k motstånd ,men det är ju extremt flexibelt , allt beror ju på hur man vill ha det

kan scanna dom om du vill, no problems

pt100 är platina hundra ohms tempgivare, hur hänger detta ihop med resten av sakerna?


Upp
 Profil  
 
 Inläggsrubrik:
InläggPostat: 18.51 2004-08-18 
EF Sponsor
Användarvisningsbild

Blev medlem: 21.52 2003-05-28
Inlägg: 1569
Ort: Skåne - Lund
Där ska egentligen sitta en Pt 100 men nu måste jag använda en 10M ohm fuktmätare.

ok. om det nu blir aktuellt med en spänningsdelning så kan jag maximera lasten med hjälp av matlab och lite 3D-plotar.

Det ska bli intressant att se hur dom konstruerar en konstantströmsgenerator.


Upp
 Profil  
 
 Inläggsrubrik:
InläggPostat: 09.33 2004-08-21 
EF Sponsor
Användarvisningsbild

Blev medlem: 12.22 2003-11-16
Inlägg: 13248
Ort: i det mörka småland
skickade ett pm till dig med min mailadress, skicka ett mail och jag mailar över dom scannade bilderna


Upp
 Profil  
 
 Inläggsrubrik:
InläggPostat: 18.51 2004-09-03 
EF Sponsor
Användarvisningsbild

Blev medlem: 21.52 2003-05-28
Inlägg: 1569
Ort: Skåne - Lund
Jag har nu hittat en R/I-tansmitter och tänkte att det är lättare att bygga om en färdig transmitter än att bygga en från scratch.


Jag har kommit fram till att den har följande schema:
Bild
R/I-transmittern kommer från PR electronics Den fungerar som så att man ansluter "sensorn" (0-1000Ohm) och får ut en ström (4-20mA).


Upp
 Profil  
 
 Inläggsrubrik:
InläggPostat: 19.24 2004-09-03 
EF Sponsor
Användarvisningsbild

Blev medlem: 21.52 2003-05-28
Inlägg: 1569
Ort: Skåne - Lund
Jag har nu hittat en R/I- transmitter och tänkte att det är lättare att bygga om en färdig transmitter än att bygga en från scratch.


Jag har kommit fram till att den har följande schema:
Bild
R/I-transmittern kommer från PR electronics.

Den fungerar som så att man ansluter en "sensor" (0-1000Ohm) och får ut en ström (4-20mA).

Schema förklaringar:
pot:arna 0_ och 100_ ställer man in noll nivån respektive 100% nivån.
Z3 och Z2 är inga zenerdioder utan spänningsregulatorer.
XMM1 mäter strömmen (4-20mA)
XMM2 mäter spänningen (0,2-1V)
texten V:20 |19,6 |16,8 är de spänningarna som uppmättes med sensor = 15, 220 och 1000 ohm

Nu är frågan hur ska jag modda transmittern så att den fungerar för en 3-6M ohm sensor :?:
och hur fungerar kretsen :?:

Båda op:arna har kondningar vilket borde betyda att de är lågpassfilter.
UA har heller ingen resistiv återkoppling så den borde vara en spännings (ström?) följare.
Men jag uppmätte en konstig ska på UA (6), den håller sig på konstant 2,4V men när sensorn kom över 1,5k så hoppa den till 20,8V precis som en komparator. Är den kopplad som en komparator eller är det spänningsregulatorerna som ställer till det.

Vidare har vi UB som borde ge spänning för att driva de 4-20mA i Q3.

På det stora hela så borde en fungera som grym föreslog dvs, Spänningsregulatorerna ser till att det går en konstant ström genom sensor. UA omvandlar sensorns spänning till ? med inställnings möjligheter mha. 0_ ,100_ potarna. UB styr mosfeten Q3 och bildar en strömgenerator.

Nå vad tror ni :?:
Har ni någon ide på hur jag ska få den att funka med 3M ohm < sensor <6M ohm
Jag har en fil med mer bilder och Multisim7-fil pt100.rar.bin [ta bort .bin och packa upp]

Jag fick en massa felmeddelanden när jag simulerade den i Multisim, förstår någon sig på multisims felmeddelanden?
ps. Jag kan också tillägga att det kan ha smugits sig in fel så lita inte 110% på ritningen.


Upp
 Profil  
 
Visa inlägg nyare än:  Sortera efter  
Svara på tråd  [ 10 inlägg ] 

Alla tidsangivelser är UTC + 1 timme


Vilka är online

Användare som besöker denna kategori: Majestic-12 [Bot] och 2 gäster


Du kan inte skapa nya trådar i denna kategori
Du kan inte svara på trådar i denna kategori
Du kan inte redigera dina inlägg i denna kategori
Du kan inte ta bort dina inlägg i denna kategori
Du kan inte bifoga filer i denna kategori

Sök efter:
Hoppa till:  
   
Drivs av phpBB® Forum Software © phpBB Group
Swedish translation by Peetra & phpBB Sweden © 2006-2010