Buggfix Plus
Aktuellt datum och tid: 06.41 2020-07-14

Alla tidsangivelser är UTC + 1 timme




Svara på tråd  [ 5 inlägg ] 
Författare Meddelande
InläggPostat: 12.40 2020-05-14 

Blev medlem: 19.17 2008-06-29
Inlägg: 91
Ort: Västerås
Hej.

Leker lite med min Automower.

Har kopplat in en wemos d1 mini på en kontakt som finns på kortet.

Problemet jag har är att signalen från klipparen är väldigt konstigt. Man ser att det är en seriell signal men potentialskillnad en mellan 1 o 0 är väldigt liten. Se den blåa signalen i bilden. Den gula är mitt skickade seriella data. RX ligger alltså hela tiden på ca 3.3v men gör små droppar om 250 mV när det skickas en nolla.

Klipparens kretskort har jag inte detaljstuderat men wemosen verkar vara raka rör mellan IC och plint.

Vad gör jag för fel? Tänkte testa med pull up/down. Elektroniken är pluggad men det är några år sen nu.

Bilaga:
IMG_20200513_214305761.jpg


Logga in för att visa de filer som bifogats till detta inlägg.


Upp
 Profil  
 
InläggPostat: 16.24 2020-05-14 
EF Sponsor
Användarvisningsbild

Blev medlem: 21.31 2005-12-15
Inlägg: 6495
Ort: Malmö
Du kanske har fel jord eller så orkar inte drivaren dra hela vägen mot jord.

En komparator kan även vara en lösning.
Alternativ två npn transistorer + några resistorer för bygga en non inverter som aktiverar över .7v


Upp
 Profil  
 
InläggPostat: 22.03 2020-05-19 

Blev medlem: 19.17 2008-06-29
Inlägg: 91
Ort: Västerås
Har labbat med detta ett par kvällar. Det lutar åt att ett är min wemos som är problemet.

Testat både med dubbel not och slängt in op ampar som en buffer.

Tack för idéer.


Upp
 Profil  
 
InläggPostat: 08.43 2020-05-20 

Blev medlem: 14.43 2007-06-14
Inlägg: 4310
Ort: Hälsingland
Vad har du för automower, nån gammal version?
Och vad får man/väntar sig du att man får ut från uart-porten?


Upp
 Profil  
 
InläggPostat: 21.58 2020-05-20 

Blev medlem: 19.17 2008-06-29
Inlägg: 91
Ort: Västerås
En 2018.
Man kommer åt all info och kan styra den.

Ett gäng tyskar har pulat med detta. Har läst med Google translate

https://www.mikrocontroller.net/topic/304526#6233473


Upp
 Profil  
 
Visa inlägg nyare än:  Sortera efter  
Svara på tråd  [ 5 inlägg ] 

Alla tidsangivelser är UTC + 1 timme


Vilka är online

Användare som besöker denna kategori: peo007 och 17 gäster


Du kan inte skapa nya trådar i denna kategori
Du kan inte svara på trådar i denna kategori
Du kan inte redigera dina inlägg i denna kategori
Du kan inte ta bort dina inlägg i denna kategori
Du kan inte bifoga filer i denna kategori

Sök efter:
Hoppa till:  
    Electrokit
Drivs av phpBB® Forum Software © phpBB Group
Swedish translation by Peetra & phpBB Sweden © 2006-2010