Buggfix Plus
Aktuellt datum och tid: 19.28 2018-12-14

Alla tidsangivelser är UTC + 1 timme




Svara på tråd  [ 7 inlägg ] 
Författare Meddelande
InläggPostat: 19.16 2018-07-30 

Blev medlem: 17.15 2008-02-11
Inlägg: 2231
Ort: Vasa, Finland
Jag är nu helt säker på att min AS3935 inte fungerar, vi hade historiens åskväder här igår och ingenting registrerade den.
Dock ser den nog "disturbers" när man enablar det.
Den klagar alltid på att noise level är för hög fast jag prövat högsta tröskelvärdet.

Mätnoden som den är kopplad till (Atmega328 + DHT22 + CC1101) står inte i kontakt med jord, den går på batteri. Linjära spänningsregulatorer.
Den är dock i källaren halv våning under marken, betonghöghus.

Har nu lagt till i protokollet att jag kan välja inom/utomhus från servern, har haft inomhus hårdkodat förr.

Har printat från kalibreringsrutinen vilken kapacitans den hittat som bäst och det kan variera lite men är hyfsat konsekvent runt 12-15.

Borde pröva om mellanvåg hörs i källaren eftersom den lyssnar på 500 kHz...?


Upp
 Profil  
 
InläggPostat: 19.51 2018-07-30 

Blev medlem: 17.59 2009-12-21
Inlägg: 3058
Den behöver väl en hygglig antenn för att funka bra ?

Låter inte rimligt att ha den under marknivå då.


Upp
 Profil  
 
InläggPostat: 20.43 2018-07-30 

Blev medlem: 17.15 2008-02-11
Inlägg: 2231
Ort: Vasa, Finland
Modulen har inbyggd antennspole.


Upp
 Profil  
 
InläggPostat: 21.03 2018-07-30 

Blev medlem: 17.59 2009-12-21
Inlägg: 3058
Ok...Men under marknivå ?

Hittade detta saxat från en annan som haft problem
Citera:
After a few weeks of replacing and testing everything from the power supply to the wiring, I finally determined the issue was probably software related. Adding a few additional milliseconds wait before and after calling the calibration routine — making sure the internal RC oscillators have time to stabilize — seemed to fix the problem. Some online have suggested re-running the calibration routine after any changes to the settings.


Upp
 Profil  
 
InläggPostat: 06.39 2018-07-31 

Blev medlem: 17.15 2008-02-11
Inlägg: 2231
Ort: Vasa, Finland
Har laborerat med när jag kör kalibreringen men den verkar nog landa på samma värden. Ska försöka sätta till lite delay. Använder detta bibliotek; https://github.com/raivisr/AS3935-Arduino-Library och ganska långt enligt exemplet.


Upp
 Profil  
 
InläggPostat: 07.27 2018-07-31 
Moderator
Användarvisningsbild

Blev medlem: 21.44 2007-02-23
Inlägg: 4146
Ort: Åkarp / Uppsala
Hur är det med störningar på 500 kHz? I bebyggda områden, speciellt inomhus eller nära hus, är det oftast fullkomligt nedlusat med störkällor.


Upp
 Profil  
 
InläggPostat: 19.06 2018-07-31 

Blev medlem: 17.15 2008-02-11
Inlägg: 2231
Ort: Vasa, Finland
Ingenting vid dagens åskväder heller.
Lade till lite delayer och flyttade tillbaka kalibreringen till före parametrarna skrivs, enligt exempelsketchen, nu väntar vi på nästa åskväder...


Upp
 Profil  
 
Visa inlägg nyare än:  Sortera efter  
Svara på tråd  [ 7 inlägg ] 

Alla tidsangivelser är UTC + 1 timme


Vilka är online

Användare som besöker denna kategori: Inga registrerade användare och 2 gäster


Du kan inte skapa nya trådar i denna kategori
Du kan inte svara på trådar i denna kategori
Du kan inte redigera dina inlägg i denna kategori
Du kan inte ta bort dina inlägg i denna kategori
Du kan inte bifoga filer i denna kategori

Sök efter:
Hoppa till:  
   
Drivs av phpBB® Forum Software © phpBB Group
Swedish translation by Peetra & phpBB Sweden © 2006-2010