Buggfix Plus
Aktuellt datum och tid: 14.50 2018-06-25

Alla tidsangivelser är UTC + 1 timme




Svara på tråd  [ 180 inlägg ]  Gå till sida Föregående  1, 2, 3, 4, 5, 6 ... 12  Nästa
Författare Meddelande
InläggPostat: 20.15 2016-05-12 
Användarvisningsbild

Blev medlem: 16.34 2004-09-06
Inlägg: 21554
Ort: Sparreholm, Södermanland N 59° 4.134', E 16° 49.743'
Så nu fungerar det som jag vill dvs servona varvar det jag vill att de ska. Håller mig på mattan och kör ca 3000mm som max.

:whoho:


Upp
 Profil  
 
InläggPostat: 20.32 2016-05-12 

Blev medlem: 16.26 2009-02-13
Inlägg: 860
Ort: Jönköping
:tumupp: :bravo: :bravo: :bravo: :tumupp:


Upp
 Profil  
 
InläggPostat: 22.07 2016-05-12 
EF Sponsor

Blev medlem: 07.47 2008-12-03
Inlägg: 6927
Ort: Hallstahammar
Kul att höra Bengt!


Upp
 Profil  
 
InläggPostat: 12.31 2016-05-13 
Användarvisningsbild

Blev medlem: 16.34 2004-09-06
Inlägg: 21554
Ort: Sparreholm, Södermanland N 59° 4.134', E 16° 49.743'
Tog en vända med att testa med lilla miniITX PC:n och det sket sig. Fungerat klanderfritt till W7/Mach3 men klara inte av att köra modern LinuxCNC.

Så nu gäller det att hitta lämplig lösning med att få in mobo med kylare och PSU i lådan som sitter monterad på svarven.
Moderkortet är i stort sett lika som miniITX PC:n, så nog bör man kunna klämma in det hela men det blir trångt.

Bilaga:
DSC_0601.JPG


Bilaga:
DSC_0602.JPG


Logga in för att visa de filer som bifogats till detta inlägg.


Upp
 Profil  
 
InläggPostat: 21.02 2016-05-13 
Användarvisningsbild

Blev medlem: 21.16 2009-02-22
Inlägg: 12994
Ort: Säter
Vad är orsaken till att det inte fungerar med miniITX?


Upp
 Profil  
 
InläggPostat: 08.11 2016-05-14 
Användarvisningsbild

Blev medlem: 16.34 2004-09-06
Inlägg: 21554
Ort: Sparreholm, Södermanland N 59° 4.134', E 16° 49.743'
Bra fråga, efter aktivering av 'maskinen' så avaktiveras detta efter några sekunder. Trodde först att det var spänningsmatningen till logiken men det var det inte. Nåt med timing av parallell ports signalerna tros vara boven i dramat som inte Linux och/eller Mesa kortet trivs med.

Så det ser mörkt ut för den lilla men eftersom alla parametrar ej är 100:a så kanske ett test längre fram kan påvisa annat.

Nåt är aningen skumt med nuvarande inställningar då utkommenderad säg F75 ej ger konstant varvtal om 15rpm (75/5mm stigning) utan varierar en aning, håller på att reda ut detta. Spontant så låter ju detta som Following Error så de parametrarna leker jag med just nu men det kan likaväl vara alla de parametrarna som har med puls längderna för steg/riktning att göra.

Så fortsättning följer....


Upp
 Profil  
 
InläggPostat: 16.40 2016-05-14 
Användarvisningsbild

Blev medlem: 16.34 2004-09-06
Inlägg: 21554
Ort: Sparreholm, Södermanland N 59° 4.134', E 16° 49.743'
Laborerat lite idag med olika inställningar och nu tror jag att jag har hittat 'hem'.

Kör nu i Quadrature Mode och servona spinner som katter :tumupp:


Upp
 Profil  
 
InläggPostat: 16.10 2016-05-19 
Användarvisningsbild

Blev medlem: 16.34 2004-09-06
Inlägg: 21554
Ort: Sparreholm, Södermanland N 59° 4.134', E 16° 49.743'
Lite smolk i bägaren boys, klantat till det när jag specade motor axlarnas dimensioner = SUCK.

Ska vara Ø10mm och jag beställde Ø12mm så det passar ju inte så bra.
Men det löser sig nog med lite svett genom att demontera X axelns kulskruv och bearbeta änden.
Z axeln kanske blir lite enklare då det verkar sitta en adapter kulskruv/motoraxel som bör relativt enkelt kunna fixas.

Jaja, det man inte har i hövve får kroppen lida för ;)

Bilaga:
DSC_0609xx.jpg


Bilaga:
DSC_0612xx.jpg


Bilaga:
DSC_0613xx.jpg


Logga in för att visa de filer som bifogats till detta inlägg.


Upp
 Profil  
 
InläggPostat: 18.57 2016-05-19 
Användarvisningsbild

Blev medlem: 16.34 2004-09-06
Inlägg: 21554
Ort: Sparreholm, Södermanland N 59° 4.134', E 16° 49.743'
Såja, grottat lite mera i vad som är vad. Ser ut att bli hyfsat enkelt att fixa till detta.

Bilaga:
DSC_0615xx.jpg


Kulskruven har en påskruvad bussning för axial lagret och är löstagbar och kan nu öppnas en bit in till Ø12mm så servomotor axeln passar och lite kilspår ska gnidas :) Hur jag löser den biten vet jag inte i skrivande stund då ½ skall vara original Ø10 och resterande Ø12 med 4mm kilspår.


Z axelns korta bussning ska få samma behandling 50/50. På nåt sätt ska detta lösas.


Logga in för att visa de filer som bifogats till detta inlägg.


Upp
 Profil  
 
InläggPostat: 10.38 2016-05-20 
Användarvisningsbild

Blev medlem: 16.34 2004-09-06
Inlägg: 21554
Ort: Sparreholm, Södermanland N 59° 4.134', E 16° 49.743'
Bilaga:
x axis bushing.PNG


Bild som åskådliggör 'problemet'


Logga in för att visa de filer som bifogats till detta inlägg.


Upp
 Profil  
 
InläggPostat: 10.44 2016-05-21 
EF Sponsor

Blev medlem: 07.47 2008-12-03
Inlägg: 6927
Ort: Hallstahammar
Kan du tänka dig att dra det nya spåret ut genom hela så är det väl lite lättare i alla fall. Bör väl inte göra så stor skada?


Upp
 Profil  
 
InläggPostat: 10.47 2016-05-21 
Användarvisningsbild

Blev medlem: 16.34 2004-09-06
Inlägg: 21554
Ort: Sparreholm, Södermanland N 59° 4.134', E 16° 49.743'
Har klurat på det, blir ett stort första ingrepp och ont om plats för verktyget.

Kommer att göra nya bussningar så jag har nåt att gå tillbaka på ifall att.

Däremot den långa gängade biten blir det värre med, hoppas kunna slå kilspåret i svarven.


Upp
 Profil  
 
InläggPostat: 10.15 2016-06-17 
Användarvisningsbild

Blev medlem: 16.34 2004-09-06
Inlägg: 21554
Ort: Sparreholm, Södermanland N 59° 4.134', E 16° 49.743'
Liten uppdatering

Ska till och montera en encoder direkt på spindelmotor axeln.

Bilaga:
enkoder.jpg

Bilaga:
3fas motor axel.jpg

Bilaga:
flexkoppling.jpg

Bilaga:
flex liten.jpg

Bilaga:
flex stor.jpg

Bilaga:
enkoder axel adapter.jpg

Bilaga:
enkoder m adapter.jpg

Bilaga:
6 till M10 mockup.jpg

Bilaga:
ihopsatt enkoder.jpg


Sen ska det till lite fästen för att montera encodern på plats.


Logga in för att visa de filer som bifogats till detta inlägg.


Upp
 Profil  
 
InläggPostat: 10.30 2016-06-17 

Blev medlem: 10.11 2007-03-19
Inlägg: 4835
Ort: Ronneby
Varför koppla enkodern till motorn och inte till spindeln?
Påminn mig, vilket styrsystem är det nu ska köra?


Upp
 Profil  
 
InläggPostat: 10.39 2016-06-17 
Användarvisningsbild

Blev medlem: 16.34 2004-09-06
Inlägg: 21554
Ort: Sparreholm, Södermanland N 59° 4.134', E 16° 49.743'
Kommer att bli LinuxCNC och Pathpilot när allt är uppe och lirar.

Enkodern är inte så enkel att få till mekaniskt vid spindelaxeln, är remdrift 1:1 så att placera den på motoraxeln fungerar ju bra.


Har ju denna varianten men det är bra mycket mera stök att få till det.

Bilaga:
DSC_0621xx.jpg


Logga in för att visa de filer som bifogats till detta inlägg.


Upp
 Profil  
 
Visa inlägg nyare än:  Sortera efter  
Svara på tråd  [ 180 inlägg ]  Gå till sida Föregående  1, 2, 3, 4, 5, 6 ... 12  Nästa

Alla tidsangivelser är UTC + 1 timme


Vilka är online

Användare som besöker denna kategori: Inga registrerade användare och 9 gäster


Du kan inte skapa nya trådar i denna kategori
Du kan inte svara på trådar i denna kategori
Du kan inte redigera dina inlägg i denna kategori
Du kan inte ta bort dina inlägg i denna kategori
Du kan inte bifoga filer i denna kategori

Sök efter:
Hoppa till:  
   
Drivs av phpBB® Forum Software © phpBB Group
Swedish translation by Peetra & phpBB Sweden © 2006-2010